CrossFit Discussion Board  

Go Back   CrossFit Discussion Board > Community > Testimonials
CrossFit Home Forum Site Rules CrossFit FAQ Search Today's Posts Mark Forums Read

Testimonials CrossFit's successes / your achievements

Reply
 
Thread Tools
Old 09-27-2006, 06:31 AM   #1
Jon Gilson
Affiliate Jon Gilson is offline
 
Jon Gilson's Avatar
 
Profile:
Join Date: Sep 2006
Location: Boston  MA
Posts: 814
I got my first muscleup today. I high fived everyone in sight. Then I got four in a row!!!!

Today is a great friggin' day!

I even got it on video--will post later...

I just watched Anthony B's first--I can relate to your excitement, bro. That's the best feeling ever, huh?

Best,

Jon
  Reply With Quote
Old 09-27-2006, 06:40 AM   #2
Anthony Bainbridge
Affiliate Anthony Bainbridge is offline
 
Anthony Bainbridge's Avatar
 
Profile:
Join Date: Nov 2005
Location: Fredericton  New Brunswick
Posts: 3,886
Yeah, it feels awesome to finally get it. AWESOME work on 4 in a row!!
  Reply With Quote
Old 09-27-2006, 10:04 AM   #3
Joe Marsh
Affiliate Joe Marsh is offline
 
Joe Marsh's Avatar
 
Profile:
Join Date: Feb 2006
Location: Las Vegas  Nevada
Posts: 433
4 in a row seems so far away. I have been toying with my rings so much, that I have been neglecting most other apsects of training, ie running, lifting, etc. I'm just like a kid at Christmas. I will be working on my third in a row for awhile. Tremendous work Jon!!!
  Reply With Quote
Old 09-29-2006, 12:43 PM   #4
Jeff Belyeu
Member Jeff Belyeu is offline
 
Profile:
Join Date: Apr 2006
Location: Houston  TX
Posts: 135
Just got my rings about a month ago. Messed up schedule, so no real consistent work on them. Some body rows, some supports/L-sits. Just letting myself get used to some of the stabilizers with the rings & zero friction. Last week I tried dips for the first time. Did 10 or so singles. First few I was conservative, then I felt good about it, so I pushed them deeper. Wasn't paying attention, but I'm guessing the next day I had some pain in my right shoulder. Has lasted about a week now, but almost gone. Is this normal/expected? I might have done something else to it, but this is the best culprit that I can think of.
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:20 PM.


CrossFit is a registered trademark of CrossFit Inc.